Accessing the API

    Server expects pass to be md5 hash, however you are running SVS in the background so there is a second try in clear text. You can ignore this message in that case.

    P.S.
    What do you mean by CE?
    Mit freundlichen Gruessen/ With kind Regards / Meilleures salutations

    Vladislav Malicevic
    VP Development & Support
    Jedox AG
    I'm experiencing similar problems with Jedox 5 when trying to connect to the server via HTTP API. Client and server are on the same machine. Connecting to the server via Excel client works.

    The following query works fine:

    Source Code

    1. http://localhost:7777/server/info


    I receive:

    Source Code

    1. 5;0;4;4218;0;0;18477;




    The following query doesn't work:

    Source Code

    1. http://localhost:7777/server/login?user=admin&password=21232F297A57A5A743894A0E4A801FC3


    I receive:

    Source Code

    1. 1004;"authorization failed";"incorrect username or password";"parameter 'user' value 'admin'";


    In the file olap_server.log I get this message:

    Source Code

    1. WARNING: error code: 1004 description: authorization failed message: incorrect username or password




    I'm using the default palo.ini:

    Source Code

    1. http "127.0.0.1" 7777
    2. log "D:\Programme\Jedox\Jedox Suite\log\olap_server.log"
    3. verbose info
    4. splash-limit 1000 500 100
    5. goalseek-limit 1000
    6. goalseek-timeout 10000
    7. cache-barrier 1000000
    8. clear-cache-cells 100000
    9. template-directory "D:\Programme\Jedox\Jedox Suite\olap\Api"


    The same HTTP API calls worked with Jedox 3.1. The algorithm, that is used to generate the password MD5 hash, hasn't changed.

    Has the HTTP API changed since Jedox 3.1?