Can't load PHP dll on WAMP server

      Can't load PHP dll on WAMP server

      Hi,

      For a project i need the php api for jedox. So i downloaded the latest SDK, taked the PHP5.5 .dll files (because WAMP use PHP5.5 at the moment, cannot use 5.6). Then i've added the following into the php.ini files of "wamp\bin\php5.5.12" AND "wamp\bin\apache\apache2.4.9\bin" :

      Source Code

      1. extension=libpalo_ng.dll
      2. extension=php_jedox_palo.dll


      In my php webpage code i've got the following code :

      PHP Source Code

      1. <?php
      2. define('host', '192.168.1.45');
      3. define('port', '7777');
      4. define('user', 'admin');
      5. define('pass', 'admin');
      6. $connection = palo_init(host, port, user, pass);
      7. $dbName = 'Demo';
      8. $dimensionsArray = palo_database_list_dimensions($connection, $dbName, 0);
      9. foreach ($dimensionsArray as $t) {
      10. echo $t;
      11. }


      But when i open my webpage i've got the following error :

      Source Code

      1. Fatal error: Call to undefined function palo_init() in C:\wamp\www\datagridjedox\index.php on line 19


      I've restarted all services of WAMP but it give me that message. When i put On/Offline the wamp server i got twices 2 popup with those messages :

      Source Code

      1. PHP Startup: Unable to load dynamic library
      2. 'c:/wamp/bin/php/php5.5.12/ext/php_jedox_palo.dll' - %1 is not a valid Win32 application
      3. PHP Startup: Unable to load dynamic library
      4. 'c:/wamp/bin/php/php5.5.12/ext/libpalo_ng.dll' - %1 is not a valid Win32 application


      I've also try to add this at the bottom of the httpd.conf file of apache :

      Source Code

      1. LoadFile "C:\wamp\bin\php\php5.5.12\ext\php_jedox_palo.dll"
      2. LoadFile "C:\wamp\bin\php\php5.5.12\ext\libpalo_ng.dll"

      But wamp doesn't start at all and no messages.

      Does somebody have any idea of what is happening ? Does i've done something wrong ?

      Cordially.