ETL Server and Oracle

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • ETL Server and Oracle

      Hi there,

      I just downloaded the XML-structure documentation for the etl-server (rel. 0.9.6, 28.01-2008) and now I am surprised that there is no 'Oracle' Type-Attribute for the <connection> - tag.

      Is there no implementation for Oracle or do I have to use some kind of workaround? Or has it been implemented within a later release (0.9.8 e.g.)?

      As it really makes no sense to replicate tables from Oracle into a mysql db and then import them into PALO I need a solution for importing data from Oracle into PALO...

      Regards,

      Harry

      The post was edited 1 time, last by harry ().

    • Hello,

      as you have deducted correctly there is now Oracle support in the current releases of the etl-server.
      The developers have not completely tested an Oracle connection yet. It is possible that Oracle support will be available in a future release of the etl-server but there is no confirmed date so far.


      best regards
      Enno
    • RE: ETL Server and Oracle

      Hello!

      I tried ETL-Server 1.0.0 (standalone installation) to connect to Oracle.

      As described in the manual I copied the JDBC-driver into the lib directory.

      This is my connection-setting within the XML-project file:

      <connection>
      <connection name="sandbox" type="oracle:thin">
      <host>a.b.c.d</host>
      <port>1522</port>
      <user>username</user>
      <password>password</password>
      <database>DBNAME</database>
      </connection>


      Setting within component.xml

      <component name="oracle:thin" driver="oracle.jdbc.driver.OracleDriver" class="org.proclos.etlcore.connection.RelationalConnection"/>

      And that's the error I get within the logs:

      2008-04-28 14:18:32,414 ERROR main org.proclos.etlcore.connection.RelationalConnection - Failed to open Relational connection sandbox. Please check your connection specification. Listener refused the connection with the following error:
      ORA-12514, TNS:listener does not currently know of service requested in connect descriptor
      The Connection descriptor used by the client was:
      //a.b.c.d:1522/DBNAME


      The Oracle version I am using:
      Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bit Production
      With the Partitioning, Real Application Clusters, OLAP and Data Mining options


      I have not any clues how to get this running.... :(

      Any suggestions?

      best regards

      Harry
      Löse das Problem, nicht die Schuldfrage (jap. Sprichwort)

      The post was edited 1 time, last by harry ().

    • RE: ETL Server and Oracle

      Hi All!

      The best way to get an answer and a solution for a problem is to solve it yourself.... ;)

      I tried to connect to the Oracle-DB by using the SID, but the jdbc-connect seems to be implemented for using the service name....

      So I set up a local service name by using the Oracle tool $ORACLE_HOME/BIN/netca and used this one for the <database> tag....

      And all of a sudden it worked :)

      COOL !!!!

      Regards,

      Harry
      Löse das Problem, nicht die Schuldfrage (jap. Sprichwort)