different dimensions, same elementnames

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • different dimensions, same elementnames

      hi all,

      i tried to create a rule for getting values into some cubes from another one.
      cube a includes some accounts: 1, 2 (dimensions: "bankaccounts", "months", "case")
      cube b includes some accounts: 3, 4 (dimensions: "customeraccounts", "months", "case")
      ...
      cube c includes all possible accounts 1, 2, 3, 4 (dimensions: "allaccounts", "months")

      the only thing i need is a rule to get values from cube c into the corresponding accounts of cube a or b (target-case would be "actual") by using a business rule. so far i didn't find out how the rule has to look like, i hope this is possible?

      i tried for example ['actual'] = N: PALO.DATA("database","c",!'months') and there are only #null! values in cube a
      ['actual', !'bankaccounts'] = N: PALO.DATA("database","c",!'months', !'allacounts') isn't possible

      thanks for your help
    • hi enno,
      thanks for your reply.
      i only use those values to be shown in a column "actual".

      hmmm, as i read your reply, i think i found a solution: i might reference the column "actual" to cube c, so then i wouldn't even have to create a rule :D i only have to calculate the consolidations in that view

      The post was edited 1 time, last by Silba ().

    • Hi Silba,

      To make the setup in your first mail work I think the rules should have been:

      in cube a:
      ['actual'] = N: PALO.DATA("database","c",!'bankaccounts',!'months')
      in cube b:
      ['actual'] = N: PALO.DATA("database","c",!'customeraccounts',!'months')

      These rules expect both the "bankaccount" leaf elements and "customeraccounts" leaf elements also to be (N or C) elements in the "allaccounts" dimension. The rules map the elements in the account dimension of the destination cube (a, b) on the elements in the account dimension in the source cube (c).

      Michel

      The post was edited 1 time, last by Michel ().

    • hi all,

      now that the rule works in palo 2.0 it doesn't seem to work in palo 2.5 anymore??? there are only value errors in the target cube.

      i attached screenshots (values from rules should show up at the right edge of the table "Ist"):
      - target cube before entering the rule in the editor
      - source cube with entered values
      - entered rule in the editor (there is no error message)
      (- after one calculation the values are still like the data before entering the rule)
      - target table after the second (!) calculation

      i tried the following general rule:
      ['Ist'] = N:PALO.DATA("TestIPCProFilBasis","WSuSaImport",!'Jahre',!'Monat',!'DDKosten')
      and the same rule only for one account with the same problem:
      ['07','1','Ist','7680'] = N:PALO.DATA("TestIPCProFilBasis","WSuSaImport","07","1","7680")
      (!'DDKosten' are accounts of the target cube. the same element-names are used in the source cube "WSuSaImport")

      is this a bug or do i have to change the rule in version 2.5???
      thanks for your help
      Images
      • vor Rule.jpg

        94.63 kB, 1,362×325, viewed 1,180 times
      • source.jpg

        140.48 kB, 1,362×443, viewed 1,488 times
      • rule.jpg

        80.03 kB, 880×556, viewed 1,492 times
      • nach 2 berechnung.jpg

        106.88 kB, 1,367×325, viewed 833 times

      The post was edited 2 times, last by Silba ().

    • sorry for bothering,
      after rebooting the problem is somehow solved.
      i don't know what was wrong, but now it works again
      :)

      #### edit: ####

      hm, now it doesn't work again... even after rebooting...
      perhaps it was a bit premature to be happy :(

      The post was edited 1 time, last by Silba ().