Palo Marker Error - markered rule gives random false values

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Palo Marker Error - markered rule gives random false values

      Markered rules sometime give wrong results.

      i.e.

      ['09/08'] = ['2009'] / [['2008']]



      2008 2009
      values 1372476 1494248

      ['09/08'] equals normally 1,09, but sometimes it gives a random number like 342121144

      Error is impossible to reproduce, server restart helps mostly (markers had been set before server start up).

      Does anybody have the same problem?

      System OS: WXP PRO SP3
      Client: Excel 2003 SP3
      Palo version: 3.0 Build 3933

      The post was edited 1 time, last by vargabor ().

    • RE: Palo Marker Error - markered rule gives random false values

      Hi,

      Results for calculations on C: level using markers are undefined. In PALO 2.5 this did not appear to be a problem (it seemed to work correctly), but in PALO 3.0 this doesn't work.
      In your case your rule now should be split into two:
      ['09/08'] = N: ['2009'] / [['2008']]
      ['09/08'] = C: ['2009'] / ['2008']

      It's a pain, but it works.

      Michel
    • RE: Palo Marker Error - markered rule gives random false values

      Thanks for the answer.

      We had the same problem in 2.5 as well.

      I can't understand this feature, usually it works and sometimes it goes wrong.

      I will try to double the rules, but this will affect the cube performance.
    • RE: Palo Marker Error - markered rule gives random false values

      Originally posted by vargabor
      I will try to double the rules, but this will affect the cube performance.


      Hi,

      Why do you think this will affect the cube perfomance? I would think this is still the same rule you had, but with a different notation (whatever notation used, the marker will always only be applicable to the N level).

      Michel
    • Hi All!

      Anyhow, the marker technology seems to suffer from several problems. I have partly migrated a model from an another tool and I always met strange behaviour when I used markers.
      I have reported for example 0004658 in the bug tracker. I would not call problem No 0003024 a minor issue either. Using markers within If function also resulted in weird events (marker was sent from the "true" side when the expression was false and the rule that came later to handle the false case remained unmarkered). In a former post I mentioned that ordering seemed to work incorrectly for markered values (maybe solved since then, I have not checked again).
      I hope that the markers will work well soon, otherwise Palo degrades to a hobby-tool.

      C.
    • RE: Palo Marker Error - markered rule gives random false values

      Originally posted by Michel
      Originally posted by vargabor
      I will try to double the rules, but this will affect the cube performance.


      Hi,

      Why do you think this will affect the cube perfomance? I would think this is still the same rule you had, but with a different notation (whatever notation used, the marker will always only be applicable to the N level).

      Michel


      That's true.