Installing Palo on Ubuntu

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Installing Palo on Ubuntu

    Dear all,

    I am new on this forum (and with Palo) and I have a few questions to ask you: I would like to install Palo on my computer (Ubuntu 9.10) because I might be hired by a consulting company who works on Palo implementation projects.

    The problem is, I have no technical background (only functional) and I could use some help to install and configure Palo.

    Can you please tell me what to do or tell me where I can find a complete tutorial explaining how to ? I copied the files and extracted the tar.gz archives, then tried to launch the "install.sh" script but it does not seem to do much. I installed MySQL yesterday, do I also need an application server ? Which one could I use ?

    Thanks in advance for your help !

    best regards
    laloune
    laloune

    Post hoc, non est propter hoc

    The post was edited 1 time, last by laloune ().

  • Hello everybody,

    I finally got to run the installation script through the console by typing "sh install.sh" with root rights.

    Still, I now have another problem: when I launch the startserver.sh script (also with root rights), I get these errors:

    Source Code

    1. (98)Address already in use: make_sock: could not bind to address [::]:80
    2. (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    3. no listening sockets available, shutting down
    4. Unable to open logs


    when I try to know which process uses currently the port 80 (sudo netstat -tulpn | grep :80), it will be told to me that tcp6 is currently using it. I guess that the server is not started then.

    Would you please mind telling me what I should do to allow worksheetserver to start on the port 80 ?

    Thanks in advance for your help

    Best regards
    laloune
    laloune

    Post hoc, non est propter hoc
  • examine the output of "sudo netstat -tulpn | grep :80" more carefully.. tcp6 is in the first column, the last column will list the PID and name of the process actually using the port... its most likely apache.. 80 is standard http port. Try shutting it down "sudo /etc/init.d/apache2 stop".. and then starting pbis.
  • by right, the palo installation will check if port 80 is used. if it is used it will recommend to use port 85.

    are you ok with reinstalling it again ?

    rename the installed /opt/jedox/pbis folder to something like pbis_old

    start up ubuntu as normally, then open up a terminal and type in sudo -i to login as root

    i have written a blog on this:
    software.krimnet.com/guide/gui…ntu-904-netbook-remix.htm

    the instruction works for ubuntu 9.04, 9.10 and with some minor changes works on rhel5 and centos5
  • Ok, I've followed your instructions but have some issues (of course!)

    First, I'm not sure if your blog entry is out of date but the only Linux version I could download was called "PaloSuite-Linux-i386.tar". I think it's just a new name. I looked inside the tar and there are a lot of similar filed/directories. Hoping this was true, I soldiered on and unpacked and installed the files. I got the warning that port 80 was in use and chose port 85 instead.

    Everything is going well and I'm able to log-in to the Palo front end via Firefox with admin login and password. However I have two questions:

    1) when I type ./serverstart.sh I get this message:
    [Fri Dec 18 19:32:00 2009] [warn] worker ajp://127.0.0.1:8009/ already used by another worker

    2) When I try to do anything in my firefox window I get a "Please wait" prompt in the top right that goes on forever.

    I'm sure I'm logged in ok but I'm wondering why I can't do anything. And don't understand the prompt that port 8009 is being used. I looked in the Palo.ini file and it shows 7777. So now I'm really mixed up!!

    Thanks for your help. I'm sure it's really easy. Everything looks like it's ready to go.
  • it is outdated by 3 months

    new things that have changed:
    1. the download file is PaloSuite-Linux-i386
    2. the default installation folder is /opt/jedox/ps

    to start the server it should be ./startserver.sh

    i received the warning as well:
    [Sat Dec 19 14:55:22 2009] [warn] worker ajp://127.0.0.1:8009/ already used by another worker

    And I do get the "Please wait" prompt

    Look in the file /opt/jedox/ps/log/apache_error_access.log

    You will see error related to
    1. the port 8009 - I have no idea what this is at the moment
    2. missing file dialog - I think this is what is causing the looping Please wait
    3. missing file error - I think this is also causing the looping Please wait

    Download the windows version and see if the two missing files are there. Then copy over to Linux.

    In the meantime, I will email the Jedox support and see if they can come up with any explanation.
  • after leaving it for 1 hour, the please wait message seems to have solved itself

    in the /opt/jedox/ps/log/apache_error_access.log

    [Sat Dec 19 16:00:26 2009] [error] (111)Connection refused: proxy: AJP: attempt to connect to 127.0.0.1:8009 (127.0.0.1) failed
    [Sat Dec 19 16:00:26 2009] [error] ap_proxy_connect_backend disabling worker for (127.0.0.1)
    [Sat Dec 19 16:00:26 2009] [error] proxy: AJP: failed to make connection to backend: 127.0.0.1
    [Sat Dec 19 16:00:42 2009] [error] proxy: AJP: disabled connection for (127.0.0.1)
    [Sat Dec 19 16:03:19 2009] [error] (111)Connection refused: proxy: AJP: attempt to connect to 127.0.0.1:8009 (127.0.0.1) failed
    [Sat Dec 19 16:03:19 2009] [error] ap_proxy_connect_backend disabling worker for (127.0.0.1)
    [Sat Dec 19 16:03:19 2009] [error] proxy: AJP: failed to make connection to backend: 127.0.0.1
    [Sat Dec 19 16:04:26 2009] [error] (111)Connection refused: proxy: AJP: attempt to connect to 127.0.0.1:8009 (127.0.0.1) failed
    [Sat Dec 19 16:04:26 2009] [error] ap_proxy_connect_backend disabling worker for (127.0.0.1)
    [Sat Dec 19 16:04:26 2009] [error] proxy: AJP: failed to make connection to backend: 127.0.0.1
  • been using it extensively for the past 3 days. the new version is good - but it takes at least 30 minutes to complete start. the worksheet server is much more usable.

    here is the reply from jedox (i have not tried it, since the etl server is on another machine)

    most of this is probably due to an error in the configuration of AJP and folder paths. For Palo Pivot and the integrated ETL server to run, please apply the following changes:

    - httpd.conf (located in ./etc/apache2/): change ports for AJP from 8009 to 8010

    - httpd.conf: remove relative path for:
    Alias /tc/web-etl ../tomcat/webapps/web-etl
    The Apache (httpd) is started with a chroot (change-root) command, so you can use an absolute path here:
    Alias /tc/web-etl /tomcat/webapps/web-etl

    - wpalo.properties (in ./tomcat/webapps/web-palo-ng/WEB-INF/classes): the setting paloSuiteConfigPath needs an absolute path including the installation directory. Example:
    paloSuiteConfigPath=/opt/jedox/ps/httpd/app/etc/config.php

    Please stop the server with stopserver.sh (and shutdown.sh in ./tomcat/bin, if you had started it), then apply these changes. Afterwards, start the server again. You may still get the AJP worker warning, but it shouldn't cause problems for now. Please try logging in again and check for errors. If your problems remain, please check the log files again.
  • The path to httpd.conf is:

    ./usr/local/apache2/conf/httpd.conf

    And for me.. the warning persists.

    root@quabuntu:/opt/jedox/ps# ./startserver.sh
    [Wed Dec 23 14:29:51 2009] [warn] worker ajp://127.0.0.1:8010/ already used by another worker

    Please wait.. still is present in top right.. and it takes a bit for it to make a connection to the "Palo local" server.

    Other things seem to work.. so far.
  • Tried the changes listed above (in the installation folder) and still get the same results. Except now user 8010 instead of 8009.

    Still get the "please wait message" for about 10 minutes. Then when I try to select the demo cube in OLAP manager I get error message 1:

    Func [getCubes|0001]: Exception Msg: Bad PALO connection type for connection name: Palo local

    I leave it alone for a few more minutes, click here then there and when I go back to OLAP manager I now get error message 2

    Palo-err_no_list_of_databases

    But the demo database is visible.

    After 15 minutes I can also now view the user list but still get error message 2. Clicking through the dimensions I get error message 3 when selecting "Regions"

    Func [getDimElems|0001]: Exception Msg: Bad PALO connection type for connection name: Palo local

    After 25 minutes I appear to have everything loaded although "Please wait" is still in the top right. No more error messages!

    After 30 minutes I can view the system cube without getting error message 3 but the "Please wait" message is still going!

    I'm going to leave it for a couple hours and see how it runs after that
  • Hmmm.. Well, ten hours later I still have the "Please wait" message on a 1.5Ghz laptop (T40). Plus I clicked on user manager, then back to OLAP manager and get the message "Palo-err_no_list_of_databases"

    The only entry in any of the logs is this:

    2009-12-24 07:29:53 WARNING: error code: 1015 description: invalid session message: old session identifier
    2009-12-24 07:29:53 INFO: user 'admin' logged in
    2009-12-24 07:29:54 WARNING: error code: 1004 description: authorization failed message: empty username
    2009-12-24 07:29:58 WARNING: error code: 1015 description: invalid session message: old session identifier
    2009-12-24 07:29:58 INFO: user 'admin' logged in

    Not having much luck :(

    Btw, I have 11 msttcorefonts in the chinook/var/fonts directory is that right? They're still in .exe form

    found another log in ../var/log/apache2 called php_error.log which has this:

    [24-Dec-2009 01:41:11] PHP Fatal error: Cannot use string offset as an array in /htdocs/app/lib/rpc/Palo.php on line 181

    It has this about 20 times

    The post was edited 1 time, last by jgibbs ().

  • some bits of info

    i have 60 fonts - which i copied from ubuntu :
    /usr/share/fonts/truetype/msttcorefonts

    if you dont have these fonts, then at the terminal just type : sudo apt-get install msttcorefonts

    i did have the messages in /opt/jedox/var/log/apache2/ but it was only recorded on the first day, when i was having problems.

    hope it works out for you, cause it seems to get better by the day. no idea why, but after 3 days, the speed is 4x faster than the previous version.