Problem With AJP Worker and Missing Files for PaloSuite-Linux-i386

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Problem With AJP Worker and Missing Files for PaloSuite-Linux-i386

    I have download the latest PaloSuite-Linux-i386 and installed it on Ubuntu Linux 9.10

    When starting ./startserver.sh , i get the following warning message:
    [Sat Dec 19 15:42:44 2009] [warn] worker ajp://127.0.0.1:8009/ already used by another worker

    I can login at 127.0.0.1:80 but when I click on OLAP Manager, I get non-stop "Please wait" at the top right corner

    From the file /opt/jedox/ps/log/apache_error_access.log :
    Sat Dec 19 15:06:15 2009] [error] (111)Connection refused: proxy: AJP: attempt to connect to 127.0.0.1:8009 (127.0.0.1) failed
    [Sat Dec 19 15:06:15 2009] [error] ap_proxy_connect_backend disabling worker for (127.0.0.1)
    [Sat Dec 19 15:06:15 2009] [error] proxy: AJP: failed to make connection to backend: 127.0.0.1
    [Sat Dec 19 15:06:57 2009] [error] [client 127.0.0.1] File does not exist: /htdocs/app/docroot/ui/studio/res/img/dialog, referer: 127.0.0.1/ui/studio/main.php
    [Sat Dec 19 15:06:57 2009] [error] [client 127.0.0.1] File does not exist: /htdocs/app/docroot/error, referer: 127.0.0.1/ui/studio/main.php
    [Sat Dec 19 15:06:57 2009] [error] [client 127.0.0.1] File does not exist: /htdocs/app/docroot/ui/studio/res/img/dialog, referer: 127.0.0.1/ui/studio/main.php
    [Sat Dec 19 15:06:57 2009] [error] [client 127.0.0.1] File does not exist: /htdocs/app/docroot/error, referer: 127.0.0.1/ui/studio/main.php

    Appreciate any help.
  • one more clue on port 8009

    Port 8009 (tcp/udp) | SANS Internet Storm Center; Cooperative ...
    4 Oct 2009 ... Port 8009 is commonly used for communication between Apache and Tomcat using the JK Connector. Seems to be the port used in the JK Connector ...
    isc1.sans.org/port.html?port=8009 - Cached -

    the startserver is taking so long as it is trying to start the palo olap server, the etl server and the worksheet server

    i wished they put all of these separately
  • Ok - hopefully this is more clear... :)

    First - If you want ETL integration, you need to edit httpd.conf (/opt/jedox/ps/etc/apache2/httpd.conf):

    This line:

    Alias /tc/web-etl ../tomcat/webapps/web-etl

    Should be:

    Alias /tc/web-etl /tomcat/webapps/web-etl


    To fix Palo Web, you need to edit wpalo.properties (/opt/jedox/ps/tomcat/webapps/web-palo-ng/WEB-INF/classes/wpalo.properties):

    This line:

    paloSuiteConfigPath=../httpd/app/etc/config.php

    Should be:

    paloSuiteConfigPath=/opt/jedox/ps/httpd/app/etc/config.php


    Secondly - there are two startup scripts... /opt/jedox/ps/startserver.sh and /opt/jedox/ps/tomcat/bin/startup.sh (and two shutdown scripts.. /opt/jedox/ps/stopserver.sh and /opt/jedox/ps/tomcat/bin/shutdown.sh).

    The first one starts PALO OLAP (palo process) and apache2/WSS3 (chinook-bin) process. You need to do this as root.. (sudo -i).

    Source Code

    1. cd /opt/jedox/ps
    2. ./startserver.sh


    The second starts ETL Server and Palo Web (tomcat process).. requires java 6.

    Source Code

    1. export JAVA_HOME=/usr/lib/jvm/java-6-sun;export PATH=$PATH:$JAVA_HOME/bin;/opt/jedox/ps/tomcat/bin/startup.sh


    You have to start both to have everything working.

    The "ajp worker" message can be ignored (for now).


    If want to see if PALO OLAP is running.. do "ps -eaf | grep palo" and look for ./bin/palo

    If you want to see if apache2/WSS3 is running do "ps -eaf | grep chinook" and you should see something like:

    Source Code

    1. root 16967 1 0 Jan18 ? 00:00:03 /chinook-Linux-i386/bin/chinook-bin -d /chinook-Linux-i386/etc -c config.xml -l /chinook-Linux-i386/etc/locale -a /chinook-Linux-i386/etc/auth -e /chinook-Linux-i386/extensions -s /chinook-Linux-i386/var/storage -f /chinook-Linux-i386/var/fonts


    If you want to see if ETL server/Palo Web is running.. do "ps -eaf | grep java | grep jedox" and you should see something like:

    Source Code

    1. root 9393 1 95 11:11 pts/1 00:00:13 /usr/lib/jvm/java-6-sun/bin/java -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=/opt/jedox/ps/tomcat/conf/logging.properties -Djava.endorsed.dirs=/opt/jedox/ps/tomcat/endorsed -classpath :/opt/jedox/ps/tomcat/bin/bootstrap.jar -Dcatalina.base=/opt/jedox/ps/tomcat -Dcatalina.home=/opt/jedox/ps/tomcat -Djava.io.tmpdir=/opt/jedox/ps/tomcat/temp org.apache.catalina.startup.Bootstrap start


    Access Palo via web browser @ localhost:85/ui/login/index.php (if installed on port 85)
  • During install, I think it tries to use port 80 (standard one), and falls back to port 85.. but you can over-ride it.

    If everything is running... "netstat -anp | grep palo" will show you the ports that PALO OLAP server is running on.. usually 7777.

    "netstat -anp | grep httpd" will show you what port apache2 is listening on.. for me its on 85

    again.. these commands need to be run as root
  • Do you get the login page? Or "Access Denied" right away? Are you using admin/admin to login? Are you on localhost or another machine when try to access?

    The administration interface has to be enabled in palo.ini file - but not recommended, as its not password protected.

    Perhaps you should try a fresh install.. just shutdown the services, do "mv /opt/jedox/ps /opt/jedox/ps.old", and re-run install script. Then make the changes I've outlined earlier again.
  • UI fix for ETL Manager

    fix no scrollbar on ETL Manager page
    # vi /opt/jedox/ps/htdocs/app/docroot/ui/common/res/css/main.css

    add the following line on top of the main.css
    -------------------------------------------------------------
    #ext-gen439 {overflow: auto;}
    -------------------------------------------------------------

    Useful link:
    software.krimnet.com/jedox/how…l-server-command-line.htm
    software.krimnet.com/palo/fix-…e-linux-i386-centos-5.htm

    Webiste:
    software.krimnet.com
  • New problem. While trying to start `sudo sh /opt/jedox/ps/startserver.sh` script I get a errors:

    hroot: cannot run command `./bin/mount': No such file or directory
    chroot: cannot run command `./bin/palo': No such file or directory
    chroot: cannot run command `./usr/local/apache2/bin/httpd': No such file or directory
    chroot: cannot run command `./chinook-Linux-i386/bin/chinook': No such file or directory

    Before all were quite good. Why this error happened I dont know. By the way ./bin/mount exists.
    Any advice?