ISERROR and DATA not working

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • ISERROR and DATA not working


      i would like to get a piece of information from another cube which has similar but smaller dimensions than my main cube. In order to achieve this, I wanted to use the PALO.DATA function and it worked fine. However, I also needed exception handling in order to handle nonexistent Elements, so I had a look at the IF and ISERROR-Functions. That however, doesn't seem to work, since an error is just displayed as if the iserror-Function wouldn't exist.

      Currently I am using the following formulas:
      ['Budget'] = IF(ISERROR(PALO.DATA("Hersteller","Hilfswürfel Budget",!'BudgetTyp',!'Benutzer',"Raw",!'Zeit')),0,1)

      ['Freies Budget'] = PALO.DATA("Hersteller","Hilfswürfel Budget",!'BudgetTyp',!'Benutzer',"Raw",!'Zeit')

      In my opinion Budget should always return a value, whereas Freies Budget can display an error. They however behave similarly. By that I mean that an error doesn't trigger the IF-Function like i believe it should.

      Any ideas?

      The post was edited 1 time, last by marc479 ().

    • Further testing revealed that it makes a difference how the values are retrieved from the Server. If I use the PALO.DATA-function, every Case works fine. DATAC, DATAX and DATAV however only work with the positive case and display #Name in case of error instead of a 0. In the ISERROR-function I tried EINDEX, EINDENT and DATA, all with similar results. The ESIBLING-Function always returned the positive case, hence also not good.

      This Post reports difficulty with a lot of rules, however even if I just use the one rule and it is simplified to just return ones and zeros it fails.

      Is this a problem with the all at once-approach of DATAC and X or the array retrieval of V or am I using the functions in a wrong manner?

      P.S. Both the stable 3.0.1 (292) and the Ramp Up 3.0.1 (496) MOLAP-Servers behave the same except for the inability to create new rules in the Ramp Up. I use Win XP Prof SP3 and Excel 2007. Fills are done with the stable Version of the ETL-Server 3.0.943 which runs Debian Lenny (MOLAP however runs on XP, not linux).

      Help and/or advice appreciated

      The post was edited 1 time, last by marc479 ().