HTTP 503 error on new ETL Server project creation

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • HTTP 503 error on new ETL Server project creation

    Hi there,

    i just installed the Palo Suite 3.1 and read through the documentation.
    Since my project involves external data from a database, this meant ETL Server usage as well.

    So i followed the documentation for ETL Server step by step, created a new project named Test, added some description, hit Save and got ...

    Source Code

    1. Project "Test" could not be [was: Server returned HTTP response code: 503 for URL:

    The tomcat logfile keeps filling with errors:

    Source Code

    1. 10.06.2010 17:20:42 org.apache.catalina.core.StandardWrapperValve invoke
    2. SCHWERWIEGEND: Allocate exception for servlet AxisServlet
    3. java.lang.UnsupportedClassVersionError: Bad version number in .class file (unable to load class com.jedox.etl.service.ComponentDependencyDescriptor)

    The system was installed on Windows XP SP3, JDK 1.5 and 1.6 (i switched to check if that works; it did not).
    I tried Firefox and IE but both did not work.
    Manual call of above mentioned URL allowed me to download the DTD.

    Does anyone have any ideas what caused this or what i might have done wrong?

    Kind Regards
  • Hi and thank you for the reply.

    I tried that by setting JAVA_HOME globally to my 1.6 JDK and after that did not work setting it inside the catalina.bat.
    The error in the log and more annoyingly the ETL Server still does not work.

    Any more hints? Anything that i might try or take a look at?
  • my setup of JAVA_HOME is locally in file at beginning of document:

    to see if java version is correct:
    testing "java -version" on /usr/local/java/bin

    java version "1.6.0_18"
    Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
    Java HotSpot(TM) Client VM (build 16.0-b13, mixed mode, sharing)

    post your logging file
  • Thanks again for your reply.

    Well, i tried jdks 1.5 to 1.7 even, and the behavior did not change.
    I am not quite sure whether the catalina.bat is overridden by some ominous configuration file somewhere, as the windows service needs some file that i cannot find (service call goes to "C:\Programme\Jedox\Palo Suite\tomcat\bin\paloTomcat6.exe" //RS//PaloSuiteTomcatService)

    Attached are my logfiles after cleaning them and restarting new (no need to have thousands of same loglines spamming this forum).

    Steps that should have been covered by the logfiles:
    - Startup
    - Logging into Palo Web via as admin/admin
    - Opening ETL Server
    - Creating new project
    - Setting name "Test", description "Test"
    - Hitting Save (aforementioned error message appears)
    - Shutting down tomcat

    Kind Regards