Error Type-26 with PALO.SETDATA()

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Error Type-26 with PALO.SETDATA()

    Hello!

    I started to use Palo this week and I found it very speed and I think that it can has powerful features with Excel ones.

    So, my problem is :
    I created a cube, and dimensions. I filled the dimensions thanks to the .PDF help.
    Now, I want to fill my cube with values. But the PALO.SETDATA function doesn't work.

    I've got these fields :

    Source Code

    1. Month (= 1 2 3 4 5 ... 11 12) in column A of Excel
    2. Year (= 2002 .. 2006) in column B of Excel
    3. Client (= a store name) in column C of Excel
    4. Product (= TV, Cars...) in column D of Excel
    5. Value (= price) in column E of Excel

    *The fields A B and E were created with the 'n' argument when I created my dimensions, and the others fields with the 's' argument.

    When I paste the PALO.SETDATA function (with the 'guess arguement' option checked), Palo found this function which is good :

    Source Code

    1. =PALO.SETDATA(value;FAUX;"Localhost/TestBI_2";"CubeTestLight";$A$1;$C$1;$D$1;$B$1)


    I changed the "value" field with that : $E$1.

    This is the result :

    Source Code

    1. =PALO.SETDATA($E$1;FAUX;"Localhost/TestBI_2";"CubeTestLight";$A$1;$C$1;$D$1;$B$1)



    The error in the Excel cell is : "#VALEUR!" (in French, so I supposed : "#VALUE!" in english).
    And when I when I clic with the right button and choose the "Palo" feature, the error message 26 which is an error about types :

    Source Code

    1. "the palo server has returned an error (Error -26)"


    Have you got any ideas?
    Please.

    Thanks a lot for your help, I have to test this software, and particularly the cube creation aspect.

    Jackybob
  • Hi!
    Ok ... I got it now ... Error -26 is kind of type mismatch error ... you were trying to write numbers into string cells .... so, either you have to modify your DB to get <number element>x...x<number element> combinations (instead of <number element>x…x<string element> which makes string cell at the end) or you have to convert values to string prior to importing them by wrapping them into something like:

    Source Code

    1. TEXT($E$1;"Standard")


    In you case the formula would look like:

    Source Code

    1. =PALO.SETDATA(TEXT($E$1;"Standard");FALSE;"Localhost/TestBI_2";"CubeTestLight";$A$1;$C$1;$D$1;$B$1)
    Mit freundlichen Gruessen/ With kind Regards / Meilleures salutations

    Vladislav Malicevic
    VP Development & Support
    Jedox AG
  • Ok.
    First thanks for helping me so quickly. It's a good point for the Palo project!
    I support you!

    After a little translation (functions in french) of your second solution, it seems to work : there is no more the error 26 and the cell contains the right value.

    BUT!
    When I use the "Paste View" function, the cells contains an Error : "#NULL!".
    It is the same error as before the good results with the import.
    So? Why this is NULL whereas the import effectively imports.?

    Is there another way to check values in the cube ?

    (and I don't understand how apply your first solution with "<number element>..<number element>"... is it in the formula? or in Palo Modeler? but this is not very important now).

    The post was edited 2 times, last by Jackybob ().

  • Hi!
    Are you sure import went trough correctly? If you try to do step-by-step import and enable screen updating, you should be able to see correct value returned back from SETDATA.

    Which DATA function do you use in Paste View (DATA, DATAC, DATAV)?

    What I meant with <number element>x<number element> is that instead of using string element to store number value, you could use number element instead, i.e. convert your string element into number element.
    Mit freundlichen Gruessen/ With kind Regards / Meilleures salutations

    Vladislav Malicevic
    VP Development & Support
    Jedox AG
  • Hi!

    During the import, the cell which gots the formula (with setdata function) displays the number well, for all records.

    In my paste view. I use the DATAC function. Which indicates a "Null!" error in Excel. I've just tried the DATA and DATAV functions, and they indicate a "Value!" error.

    Here the Palo errors :
    - Palo.DATA : displays "#VALUE!" and Palo says : "the palo server has returned an error (-29)"
    - Palo.DATAC : displays "#NULL!" and Palo says : "the server has returned an error : (-26) (Error -75)"
    - Palo.DATAV : displays "#VALUE!" and Palo says : "returned value is of invalid type"

    Thanks

    [edit] Notice that the errors above occur when I paste the view with "all product" in column (="Tous les produits" in my example). This data is a consolidate element.
    If I paste the view with the level 2 of the products in column (string elements) there is no error, but the table is empty (with the formula "=PALO.DATAC($A$1;$A$2;$A$3;$A$4;$A8;B$6" for one of the cells).
    I don't know if it can help.

    The post was edited 2 times, last by Jackybob ().

  • Maybe nobody can find a solution?
    Please help, I'm in the hurry! ;(

    (maybe I can recreate a thread in the Paste View section which is more appropriate...?)

    Here the database (from Jedox Folder), the file for importing cube and the file with the paste view which doesn't work.
    Files
    • Example.zip

      (26.41 kB, downloaded 543 times, last: )
  • Hi!
    It looks like you are using string elements inside consolidation which does not seem to have much sense aside eventually for using it with attributes... any combination of string cell with number cell will produce again string cell ... Palo is not sure what to do in that case and renders error ... so to keep the story short ... problematic is the Dimension "Adherents" ... if you change all of those consolidated elements to type numeric ... error should go away.
    Mit freundlichen Gruessen/ With kind Regards / Meilleures salutations

    Vladislav Malicevic
    VP Development & Support
    Jedox AG
  • OK, I am sorry, the error was mine... :(

    My SQL request returns only 24 records, and the PasteView that I wanted to show don't contains any of these records. Sorry for loss of time... :D


    BUT, I will check much closer the error on lines with consolidate value... and post in the good part of the forum in case of problems..

    THANKS and SORRY!!
  • String value in the SETDATA function

    Good morning,

    if I try to use the palo's SETDATA function to f.e. save value to all elements under the consolidated one using the !! prefix in the code like this:

    SetData = Application.Run("PALO.SETDATA", "!!300", TRUE, sServer, sCube, sCoordinate1, sCoordinate2, sCoordinate3, sCoordinate4, sCoordinate5)

    I get an "error 2000". If I do the same on paste view(on the sheet), I write "!!300" into the cell, then everything is just fine(the same value is on all basic elements under the selected consolidated one). But in the code the value ("!!300") cannot be sent as a numeric value, but only like a string variable, which the SETDATA function doesn't accept and therefore I get the error mentioned before. Could you tell me how to make it work even int he code ? :)) Thanks a lot

    The post was edited 1 time, last by vesi ().