Importing Elements to Dimensions with odbc

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Importing Elements to Dimensions with odbc

    Hi, we have problems with importing elements to our dimensions. Basically it works fine with "palo.eadd" ant the excel-sheet "metadataimport.xls". With data like "year" or "month" it works but with data like "products" only some elements are being imported. We're importing with odbc from databases on our IBM i5. It seems that the problem occurs, when the element has special characters like "-" or just spaces.
    When we add those "product"-elements manual it works, this is pretty strange.

    Is there anything to consider when importing elements with odbc?

    Regards,
    Jens

    The post was edited 2 times, last by perga ().

  • RE: Importing Elements to Dimensions with odbc

    Hi!
    I’m not sure if you are getting “wrong” data from ODBC or is it the Palo Importer the one that does wrong interpretation of data. You maybe need to do some tweaking of your ODBC driver. It is possible that “special” characters have some special meaning. Try step-by-step “looping” through the recordset with screen refreshing turned on to see if you are getting “good” data from your ODBC source. If these data prove to be Ok, you could try parsing this data in Excel (CONCATENATE, TEXT,…) prior to submitting them to Palo.
    Mit freundlichen Gruessen/ With kind Regards / Meilleures salutations

    Vladislav Malicevic
    VP Development & Support
    Jedox AG
  • :D Thanx for your answer, we've solved the problem. With odbc we get a field with fixed length. for example the field "customer" has a length of 50 and the entry in the field is only 27 char's. excel shows the field as 50 char's long; with excel function "Trim" we've removed the spaces to the correct 27 char's and it worked. ;)

    Regards,
    Jens