Error when trying to create new connection in Palo Excel AddIn 3.2 CE

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Error when trying to create new connection in Palo Excel AddIn 3.2 CE


    I just installed Palo 3.2 CE on Win7 (64bit) with Office 2010 (32bit) and the installation worked fine so far. I can access ETL Manager and create dimensions and cubes and so on.

    Now, when I start the Excel AddIn, the small window with the responsible people of the Jedox team shows up. I click OK and it pops up again. I just point that out in case it might give somebody a hint on what's wrong.

    Then I try to add a connection to the server. I go to Add-Ins / Palo / Modeller and start the wizard. I select to register a new server, and enter the name of the connection, the server, the port and also username and password (admin/admin). When I click on test connection it works fine. And then I try to click on Continue and the following error message shows up (it's translated from german, because everything is german on that machine and I didn't want to mix up languages):

    Error when registering the server! Please check the connection parameters.

    I was used to that behaviour in the previous version of the CE. There I just clicked on OK, then I clicked on Finish in the wizard and everything worked fine. But it doesn't work in 3.2 CE. The error message just shows up as long as I try to add the connection. Adding the connection directly to the registry doesn't work either. Then I can select the server from the dropdown, but when I click on the connect button, nothing happens. Even the connection to localhost which has been added to the wizard automatically doesn't work. Nothing happens when I click on the connect button.

    So I had a look at the logfile (PaloXLAddin.log). In the log file I found an entry with (again translated from german):

    Error registering server!
    Exception Data:
    System.Runtime.InteropServices.COMException (0x800A03EC): The macro 'PALO.REMOVE_CONNECTION' can not be executed. The macro is not available in this workbook or all macros have been deactivated.

    So I thought I should check the security settings for macros and set everything to the lowest possible things I found. - same result, it doesn't work.

    Any ideas? ?(

    Kind regards,

    Christian Herzog, Senior Consultant, Vector SW DV GmbH
  • Hi Christian,

    did you look at this:…p?page=Thread&postID=7678
    Did you try to reinstall with admin rights and for all users?
    Did you try to run excel with admin rights?
    Can you access the Molap Server from the machine's browser?

  • Doesn't work with the premium edition too.


    - the other forum thread didn't help a lot. I tried to deactivate the addin, but it didn't work. But I saw that there are 2 addins ("Palo Add-in for Excel" and "Palo integration for Excel 2007"). The second one isn't active. when I click on it I see a status message like (not loaded - there was a runtime error when loading the com-addin). deactivating or deleting one of them doesnt work either.
    - yes, I installed for all users with admin rights
    - yes, I ran Excel with admin rights
    - yes, I can access the Molap Server from the machine's browser. It only seems to be a problem with the Excel addin.

    I also installed the Premium Edition and found out it's exactly the same behaviour with it.

    Kind regards,

    Christian Herzog, Senior Consultant, Vector SW DV GmbH