Loaded and filled Cube doesn't show the data, but export it

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Loaded and filled Cube doesn't show the data, but export it

      I noticed a problem as follows:
      1) ETL-Load into Cube works fine, success was stated, no errors or warnings, BUT:
      2) Then cube was (tried...) to examine via Excel, Web-Spreadsheet and Palo Analyzer --> empty, when choosing all dimensions as All and only one small dimension and Measures on the grid; activating zero suppression, nothing remains displayed indicating it's really empty
      3) Cube-properties indicate that data is loaded (cells filled)
      4) .csv-export of cube data definitively result in data in the text file, so it exists in the cube as stated by ETL and Cube properties

      Until now I never needed to activate a cube after loading or something like this. Manual inserting works anyway.

      So my question is: Are there typical pitfalls I might have ignored? Is this a known issue? Some ideas somebody?

      Any hint is highly (and desperately :| ) appreciated...

      Best regards,
    • Hi, thanks a lot for the reply.

      Really, it was an consolidation bug... unfortunately the frontends look like no values contained on zero suppression, good to know this...

      Now I noticed, that my dimension elements are typed as S-type, not N-type. But I can't find something to influence this in ETL... I guess it's similar to TM1, that atomic elements need to be "numeric" even if they have string content?
      The dimensions was loaded sequentially, and now the consolidation would look good in OLAP Manager, if the atomic elements would be numeric... (All Countries indicated as a C-Element, below of that several S-Elements as the atomic level).

      How could I determine the ETL-Process to write the elements as numeric? I used a TreeFH Transform to generate the dim's hierarchy, and configured Global element type = Numeric; but this has no effect.
      Any other switch somewhere...?
    • I got it. It's not sufficient to have only one dimension with leaf elements = numeric to ensure, that the consolidations aggregate the values, but needed for alle dimensions in the complete cube, as it seems. Thats why I had no success when changed the Global element type to numeric only in one TreeFH-transformation in ETL. It worked, but had only effect to the cube after doing so for all...

      Here is a referring post, which gave me the hint: jedox.com/community/palo-forum…page=Thread&threadID=2944