Desperate: can't start ETL or Tomcat server

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Desperate: can't start ETL or Tomcat server

      Hi there,

      today i tried to install Palo web suite 3.2. I've read all hints about this issue in this forum, but still can't resolve it.

      Problem is as follows:

      System: Windows 7 x64, with JDK x86 installed in c:\Java\jdk

      Variable JAVA_HOME is set to "C:\Java\jdk"

      startup.bat works without error message.

      When I run Palo Web and open ETL-Server I get the error message "ETL server login is not available"

      Then I remove the tomcat service and reinstall:

      c:\Program Files (x86)\Jedox\Palo Suite\tomcat\bin>servi
      Installing the service 'PaloSuiteTomcatService' ...
      Using CATALINA_HOME: c:\Program Files (x86)\Jedox\Pal
      Using CATALINA_BASE: c:\Program Files (x86)\Jedox\Pal
      Using JAVA_HOME: C:\Java\jdk
      Using Log Directory: c:\Program Files (x86)\Jedox\Pal
      Das System kann die angegebene Datei nicht finden.
      Using JVM: C:\Java\jdk\jre\bin\server\jvm.d
      Server Minimum bound = 256 Megabytes
      Server Maximum bound = 1024 Megabytes
      The service 'PaloSuiteTomcatService' has been installed.

      Still problem not fixed.

      Then I try to start service via Windows interface and get an error message 0

      The jakarta_service_20130304 log says:

      [2013-03-04 15:44:51] [614 prunsrv.c] [error] Failed installing PaloSuiteTomcatService service
      [2013-03-04 15:44:51] [info] Procrun finished.
      [2013-03-04 15:45:34] [info] Procrun ( started
      [2013-03-04 15:45:34] [info] Service PaloSuiteTomcatService name PaloSuiteTomcatService
      [2013-03-04 15:45:34] [info] Service PaloSuiteTomcatService installed
      [2013-03-04 15:45:34] [info] Procrun finished.
      [2013-03-04 15:45:34] [info] Procrun ( started
      [2013-03-04 15:45:34] [info] Updating service...
      [2013-03-04 15:45:34] [info] Service PaloSuiteTomcatService updated
      [2013-03-04 15:45:34] [info] Update service finished.
      [2013-03-04 15:45:34] [info] Procrun finished.
      [2013-03-04 15:45:34] [info] Procrun ( started
      [2013-03-04 15:45:34] [info] Updating service...
      [2013-03-04 15:45:35] [info] Service PaloSuiteTomcatService updated
      [2013-03-04 15:45:35] [info] Update service finished.
      [2013-03-04 15:45:35] [info] Procrun finished.
      [2013-03-04 15:48:15] [info] Procrun ( started
      [2013-03-04 15:48:15] [info] Running Service...
      [2013-03-04 15:48:15] [info] Starting service...
      [2013-03-04 15:48:16] [info] Error occurred during initialization of VM
      [2013-03-04 15:48:16] [info] Could not reserve enough space for object heap
      [2013-03-04 15:48:16] [info]
      [2013-03-04 15:48:16] [395 javajni.c] [error] CreateJavaVM Failed
      [2013-03-04 15:48:16] [1000 prunsrv.c] [error] Failed initializing java c:\Program Files (x86)\Jedox\Palo Suite\tomcat\bin\bootstrap.jar
      [2013-03-04 15:48:16] [1269 prunsrv.c] [error] ServiceStart returned 2
      [2013-03-04 15:48:16] [info] Run service finished.
      [2013-03-04 15:48:16] [info] Procrun finished.

      Please, please provide a solution as I couldn't find an answer in this forum or elsewhere.

      Thanks a lot in advance!


    • 1)
      paths with spaces are BAD

      try to replace them with their short versions (DIR /x IIRC - otherwise try DIR /?)

      In a similar situation I had to install a 32bit Java version and deinstall the 64bit variant before that. The Jedox Trial 4 runs in my Windows 7 64bit virtual machine with a 32bit Java runtime.

      Put the logs anywhere where it is allowed to write or change the permissions.
      Having log under "c:\Program Files (x86)\" is definitely bad practice.
    • ?offical statement and solution?

      hi zen, that doesn't sound good.

      oracle canceld the support of Java 6. so my company refuses the us of java 6 and we are only allowed to use java 7
      the problem ist the connection between the tomcatserver, java and palo etl.

      @jedox: what is your offical statement? can you offer a solution? is there a free version which runs with java 7
    • Palo ETL 3.2 has not been tested under Java 7 but I see no reason why it shouldn't work.
      Installation is somehow more complicated in 3.2 if 32-bit and 64-bit JRE is available, compared to ETL 4.0.

      Concerning the question about free version take a look at:…page=Thread&threadID=3845

      ETL Server and the Command Line Client will remain Open Source with full functionality and will be updated regularly. Only the ETL Manager will no longer be Open Source and free. Of course, the next version ETL 5.0 will support Java 7.
    • problem solved!!

      Hi fellas,

      At first thank you very much for your help. My tomcat is now running under java 7.0.170

      But I solved it in a different way. Honestly I got a bit help from the Jedox-hotline, many thanks. :love:

      1. [align=left]What did i do?[/align]

      2. [align=left]Stopped the tomcat service[/align]

      3. [align=left]Uninstall Java6[/align]

      4. [align=left]Install Java7[/align]

      5. [align=left]Now the trick: go to ..\Jedox\Palo Suite\tomcat\bin and run first serviceRemove.bat and second serviceInstall.bat[/align]

      6. [align=left]Don't forget to adjust the JAVA_HOME-Variable - (in German) Systemeigenschaften - Umgebungsvariablen - Systemvariablen - JAVA_HOME -> ..\Java\jre7[/align]

      7. [align=left]start the Tomcat service[/align]

      Now the ETL-Server is via Browser back.