php with 1.5

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hi,

    I have the same problem. On my local machine (XAMPP 1.5.5: Apache 2.2, PHP 5.2.0) everything is OK.

    On our server (the same XAMPP-version, but WinServer2000 and not WinXP) I get that error.

    Apache-errorlog:

    Source Code

    1. PHP Warning: PHP Startup: Unable to load dynamic library 'E:\\xampp\\php\\ext\\php_jedox_palo.dll' - Das angegebene Modul wurde nicht gefunden. in Unknown on line 0

    The post was edited 1 time, last by digganet ().

  • It's not better over here:

    PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\Programme\\xampplite\\php\\ext\\php_jedox_palo.dll' - Diese Anwendung konnte nicht gestartet werden, weil die Anwenungskonfiguration nicht korrekt ist. Zur Problembehebung sollten Sie die Anwendung neu installieren.\r\n in Unknown on line 0

    Looks like the libpalo_ng.dll is not loaded (to me)?
  • no, it cannot be loaded and denies to do so. Is it correct from the entries here to say that it worked in local setups where the addin also had been installed? Which is usually not the case in a pure server environment (due to the lack of office applications)?

    Ciao,
    Mario
  • I'm afraid I cannot accept to have to install (and license) a copy of Microsoft office in order to run the server. Any solution from Jedox? Or has anybody identified which components of the client installation are required?

    An installation of the client w/ Office installed stops immediately.

    Ciao,
    Mario
  • Hi again,

    I put the file into nearly all directories I could think of (especially C:\Programme\xampplite\apache\bin), and get the same result (see the error message from yesterday). I even put it into c:\windows and c:\windows\system32 which are definitely in the path ;)

    Is there any test method that I could use to determine the correctnes of the installation in single steps (like using regsvr32 -i dllname)?

    Thanks,
    Mario
  • Hi!
    Most of our Windows binaries also depend on proper version of VC++ runtime libraries. Maybe you don't have the same version of those on your machine. Solution would be either to compile PHPPalo and libpalo_ng on your own against the version you have (source code is in SVN repository on SourceForge). If you have the latest version of VS2005 and latest SP for it, then it should be allready there.

    As a workaround you could use {PALO_CLIENT_DIR}\Patches\vcredist_x86.exe from some machine where you have Excel and Palo running and then run it on the target machine.

    Somehow Microsoft guys haven't find the way to update their download website for files in question (it is still pointing to the old version of VC++ redist):

    microsoft.com/downloads/detail…0b62a191ee&DisplayLang=en

    Anyway, this explains how come digganet's solution is working - installing client setup also installs proper VC++ runtime libraries.

    I hope this helps.
    Mit freundlichen Gruessen/ With kind Regards / Meilleures salutations

    Vladislav Malicevic
    VP Development & Support
    Jedox AG
  • Originally posted by v_malicevic
    As a workaround you could use {PALO_CLIENT_DIR}\Patches\vcredist_x86.exe from some machine where you have Excel and Palo running and then run it on the target machine.



    Haleluja! phpinfo() says that I have it in there now!

    Thanks,
    Mario