[SOLVED] Database <#> has nonempty journal file from old version

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Database <#> has nonempty journal file from old version

    Hi everyone,

    I am a veteran IT Professional, but a complete newbie to the world of Jedox / Palo, so please forgive me ignorance in this area.

    I am currently undertaking a Jedox / Palo migration for a client from an older version (I'm sorry, I don't know which version), to Jedox 5.1 SR2 (free). I have been given a copy of the 'Palo Suite' folder from the old installation and have (I believe) successfully installed Jedox on the new server, copied the data files into the correct location, and started the Jedox service ok.

    In order to get the Jedox service to start, I had to substitute the original 'OLAP\Data\System' folder from the original server with the default one that was created during the installation process. I'm not sure if this is the correct move or not, but attempting to start the service with the old System folder resulted in an error (similar to the one listed below) and it was the only way I could get it working. This may be related to the rest of my problem.

    Reading the Jedox log file I see a number of critical client databases fail to load with the following error:

    2014-11-17 16:31:08 ERROR: cannot load database 'UCG'
    2014-11-17 16:31:08 ERROR: message 1: database 8 has nonempty journal file from old version

    I am assuming that this is due to the version differences between the old system and the new, however I have been unable to find any information on either the errors I'm getting or any process for upgrading the databases to the new version.

    From Excel the users can connect to the Jedox server and list some databases, but not any which list the above error.

    Is anyone able to enlighten me on what is required here? Any assistance or pointers in the right direction would be greatly appreciated!



    The post was edited 1 time, last by sam.nsp ().

  • Hi,
    when data is changed in Jedox OLAP databases, OLAP Server keeps a list of these changes in the so-called journals (the *.log files inside the database directory). These journals are used if the server cannot commit commit its data from RAM to hard-disk in normal way on shutdown, e.g. if your server crashes. OLAP then uses these files on next startup. The structure / processing of these journals can change between versions however, so the files are flagged with a version info; if a file from a version that is too old is present, OLAP refuses to process it and doesn't load the db. That's what is happening in your case.

    There are two options:
    - set up the original version again, and make sure journals are properly processed (one regular startup / shutdown should do)
    - remove any not-empty *.log files from the database directory. Note that when doing that, you will lose the changes that were logged in those files.