Single sign-on (SSO) not working for Jedox Web / Excel add-on

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Single sign-on (SSO) not working for Jedox Web / Excel add-on

    Hi there,

    Just purchased Jedox Premium and installed OLAP, Web and Integration modules on a windows server 2008 R2.
    Everything works fine, except for the SSO...

    I followed the exact procedure as described in the admin manual:
    - executed setspn command
    - added 2 lines in palo.ini:
    • worker "C:\Program Files (x86)\Jedox\Jedox Suite\svs\SupervisionServer.exe"
    • windows-sso
    - set CFG_AUTH_SSO to true in config.php

    restarted all services

    Created Active Directory Group (of which my account is a member)
    Created a group in jedox system manager with exactly the same name as the AD group: DOMAIN\groupname and assigned admin role to it. Yes it is active.

    On my client machine (windows 7) I have added the jedox web to the trusted sites.

    When I open the url http://myjedoxserver/ui/login/ I get a red error block with error message: LOGIN FAILED! "missing username, win-sso is disabled" (#1004)
    When I go to the url myjedoxserver/ub/sso I get the message "User "DOMAIN\myusername" logged in."
    When I try to connect through excel add-on with option "Use windows authentication", I get the following message: "Logon error! Invalid login-data."


    Anybody out there who successfully configured SSO in Jedox?
    Something I am missing here?

    Any help would be highly appreciated!

    Cheers,
    Tom