No server-connection with client 1.5

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • No server-connection with client 1.5

    Hi,

    after some problems I got Palo server & client 1.5 installed on our server (Win2000 Server).

    Connecting local:
    - srv01:7777: works fine.
    - Excel on srv01:7777: works fine
    - PHP on local XAMPP (Apache2, PHP 5.2.0): works fine

    Remote connecting via Palo Client 1.0 (WinXP, Office 2K)
    - srv01:7777: works fine
    - Excel on srv01:1234: works fine
    - calling palo_commands.php on server: works fine

    Remote Connection via Palo Client 1.5 (client & server installed local, WinXP, Office 2003)
    - srv01:7777: works fine.
    - Excel on srv01:7777 doesn´t work. Error: Fehler beim Verbindungsaufruf.
    - calling palo_commands.php on server: works fine
    - calling local palo_commmands.php (settings: srv01, 7777) doesn´t work. Error: Warning: PHPPalo error: connection refused in C:\xampp\htdocs\_palo\palo_commands.php on line 91
    palo_connect() failed: #NULL!


    The servers logfile is attached.

    Any ideas what´s going wrong? I need that Excel-connection to administrate the servers databases.
    Files

    The post was edited 1 time, last by digganet ().

  • Hi!
    On which network interface is Palo listening on the remote server (localhost will not do the work)? Aside from that you could check an make sure that no firewall is blocking traffic between the client and the server.
    Mit freundlichen Gruessen/ With kind Regards / Meilleures salutations

    Vladislav Malicevic
    VP Development & Support
    Jedox AG
  • Hi,

    thanks for all help. I got it. The Palo-server on srv01 was listening on 7777 (admin: 7778).
    The firewall was my first idea. But if I stopped it, the problem appeared.

    Now I changed the settings in palo.ini from "http srv01 7777" and "admin srv01 7778" to "http "" 7777" and "admin "" 7778". Now I get a connection with my local client to the server on srv01 with the following settings in the excel-connection-manager: srv01, 7777, admin, admin.

    The post was edited 2 times, last by digganet ().