Enterprise rules

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Enterprise rules

      Hello all,
      I have tested enterprise rules in the following simple situation.
      One cube localhost/testp, two dimension Projects, Values (Units,Amount). Unit price has been defined like one numeric attribute of Projects.

      ['Amount'] = ['Units'] * PALO.DATA("localhost/testp","#_Projekty","Unit price",!'Projects')

      Rule editor does not return any erro messages, but in Excel sheet is always
      #NULL! even testing data were entered, of course.

      What could be wrong? Simillar function directly entered in the same sheet works but not in the Rules editor.
      Functions in Palo use usually ; as separator between parameters but in this editor , instead.(?)
      Thanks for some idea.
    • RE: Enterprise rules

      Hi Ldivis

      The current rule engine throws # Null if it runs out of power (not a very accurate technical description I know, but what I mean is that it is hard to predict but seems to happen either with very complex rules or rules that depend on other rules).

      This is why some of us are just a bit unhappy that PALO 2.1 got delayed by 3 months!

      It may be that your reference is absolutely correct, but check for extra or missing blank spaces or misspellings in the PALO.DATA reference. I think it may also be case sensitive. I don't think the rule editor would be able to tell you if these were incorrect.

      The separator depends on your country settings - here in UK we use "," for everything and have to translate the examples where ";" is used.

      I wasn't aware that the rule editor alway uses "," regardless of your localised settings. Interesting
      Best wishes

      John Hobson
      The Planning Factory, Lytham, UK
    • RE: Enterprise rules

      Hi Pommie,
      thank you for your remarks. I am studying Palo and searching where are basic limitation of usage and what solution is to good for. I like it but I am suprised with this simple task. I am looking for my fault at first but after hard night I do not know. I have prepared so simple sample. Only two dimensions "project" and "pvalue", one cube "pcube" and only one attribute of "project" named "price". Names with small charakters. In the enclosed sheet is in the separated cell tested used function PALO.DATA().
      I it OK but in the rules.... #NULL! again.
      I have tried:
      ['amount'] = ['unit'] * PALO.DATA("localhost/testp","#_project","price",!'project') or
      ['amount'] = ['unit'] * PALO.DATA("localhost/testp","#_project","price","project")
      and a lot of variants.
      In the manual is some more complicated sample with two nested PALO.DATA () function on th page 304.
      I have got it!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      ['amount'] = ['unit'] * PALO.DATA("testp","#_project","price",!'project')
      Name of the database has to be without servers name, it means "testp" instead of full identifikation "localhost/testp". :D So easy and simple.
      Lubos Divis
      • testp.zip

        (12.69 kB, downloaded 594 times, last: )
      • testp_xls.zip

        (2.48 kB, downloaded 462 times, last: )

      The post was edited 5 times, last by ldivis ().

    • Hi Lubos

      Try this:

      ['amount'] = ['unit'] * palo.data("testp","#_project","price",!'project')

      You don't want to put the server ID in the rule (I think because the rules can in fact only apply to rules within the same Server.)

      You do need it in the rule as a spreadsheet could have references to multiple servers in different cells.

      The combination of different quote characters takes some getting used to too doesn't it. It would be good if this could maybe be rationalised in some way.

      Happy Christmas


      Just noticed you msut have worked it out as I was looking at it :)
      Best wishes

      John Hobson
      The Planning Factory, Lytham, UK

      The post was edited 3 times, last by Pommie ().