Xmla Ssas

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Hy All,

    I use Palo web client. I tried to connect a ssas server after modifying
    the parameters in the palo.properties file.

    The connection parameters are as follow :
    server3.dispname=MS AS 2005

    A virtual dir is created mapped in IIS for the msmdpump.dll file.

    I get tis message at connection
    Application may behave incorrectly.
    Call fail on server.
    Reason: The call failed on the server; see server log for details

    The localhost log file on TomaCat server contains the following
    (the user 'PaloWeb' we use is created on the sql server we tried also creating this user as windows user. In the connection parameters we also tried with and without the user password but still have the same error)

    10 mars 2008 09:59:34 org.apache.catalina.core.ApplicationContext log
    GRAVE: Exception while dispatching incoming RPC call
    com.google.gwt.user.server.rpc.UnexpectedException: Service method 'public abstract com.tensegrity.palowebviewer.modules.paloclient.client.XFolder com.tensegrity.palowebviewer.modules.engine.client.IEngineService.loadFavoriteViews()' threw an unexpected exception: com.tensegrity.palojava.PaloException: Could not login to xmla server 'localhost' as user 'PaloWeb'!!
    at com.google.gwt.user.server.rpc.RPC.encodeResponseForFailure(RPC.java:361)
    at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:547)
    at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall(RemoteServiceServlet.java:265)
    at com.google.gwt.user.server.rpc.RemoteServiceServlet.doPost(RemoteServiceServlet.java:187)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:228)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:216)
    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
    at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:634)
    at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:445)
    at java.lang.Thread.run(Unknown Source)
    Caused by: com.tensegrity.palojava.PaloException: Could not login to xmla server 'localhost' as user 'PaloWeb'!!
    at com.tensegrity.palo.xmla.XMLAConnection.getServerInfo(XMLAConnection.java:532)
    at com.tensegrity.palo.xmla.XMLAServer.getInfo(XMLAServer.java:27)
    at org.palo.api.impl.ConnectionImpl.<init>(ConnectionImpl.java:75)
    at org.palo.api.impl.ConnectionFactoryImpl.newConnection(ConnectionFactoryImpl.java:111)
    at com.tensegrity.palowebviewer.server.PaloConnectionFactory.createConnection(PaloConnectionFactory.java:30)
    at com.tensegrity.palowebviewer.server.ServerConnectionPool.openConnection(ServerConnectionPool.java:51)
    at com.tensegrity.palowebviewer.server.ServerConnectionPool.tryGetConnection(ServerConnectionPool.java:73)
    at com.tensegrity.palowebviewer.server.ServerConnectionPool.getConnection(ServerConnectionPool.java:62)
    at com.tensegrity.palowebviewer.server.ServerConnectionPool.<init>(ServerConnectionPool.java:38)
    at com.tensegrity.palowebviewer.server.GlobalConnectionPool.getConnection(GlobalConnectionPool.java:70)
    at com.tensegrity.palowebviewer.server.GlobalConnectionPool.getConnection(GlobalConnectionPool.java:59)
    at com.tensegrity.palowebviewer.modules.engine.server.EngineLogic.loadFavoriteViews(EngineLogic.java:294)
    at com.tensegrity.palowebviewer.modules.engine.server.EngineService.loadFavoriteViews(EngineService.java:177)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:528)
    ... 16 more

    Thanks for any Help
  • RE: Xmla Ssas


    your connection settings seem to be ok.
    Have you tried accessing SSAS via a browser (firefox or ie)?
    Try to visit "http://localhost/olap/msmdpump.dll" and see what happens. If it says that the "post syntax is invalid", it means you can connect to the site.

    If that's not the case: Did you set up SSAS for use with XMLA? To do that, you will have to add a role to the SSAS. The users that will have to have priviliges in that role are:

    IUSR_<your computer name>
    SYSTEM (for windows XP, it's usually NT_AUTHORITY/System)
    <your user name>

    after you added that role, restart the IIS and try again.

    Please tell me if that helped.
    Good luck,
  • RE: Xmla Ssas


    hmmm... The HTML 500 error seems to indicate that there's a problem in the configuration of your IIS.

    So, first of all, are you running Vista or XP? (Or a different version of Windows?)
    Which version of IIS are you running?

    Can you verify that you have created the connection pool (or virtual folders) as described here.
    Especially, can you verify that your user (palo_web) has read, execute, and list rights for the application pool in which you run your msmdpump.dll.

    Also (just to make sure), please check that you are using the correct port (although an html 400 error would be expected if you used the wrong port).

    Hope that helps,

    The post was edited 1 time, last by philipp ().

  • RE: Xmla Ssas

    Ok, then what's the name of your virtual directory?
    And what are the contents under that directory?

    If your virtual directory is called "olap", _and_ the path to which your virtual directory points contains the "mdmdpump.dll", it _should_ work...

    Note that the virtual directory you created matches the name of your link. Also, if you do not have the msmdpump.dll (directly) under the virtual directory, it won't work.

    So, if you have for example:


    and you named your virtual directory "olaptest" and made it point to c:\MyOlapDirectory, your connection string would be:


    But you said you are getting a 400 error now, instead of a 500 error: What is it that you changed?

    Also: Did you restart the IIS (or if in doubt: Restart your computer...)?

    We'll get this to work! :)
  • RE: Xmla Ssas

    I created a dir under inetpub named _olap
    (C:\Inetpub\wwwroot\_Olap) and copied to it the contains of
    the C:\Program Files\Microsoft SQL Server\MSSQL.2\OLAP\bin\isapi

    The vitual dir is namped olap and points to the C:\Inetpub\wwwroot\_Olap
    now i get the error 403 when browsing then url
    localhost/olap (ie connects but access seems to be refused)
  • I get another error as i switched off the option of friendly http messages deisplay from IE.
    Browsing to

    shows the following code
    - <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
    - <soap:Body>
    - <soap:Fault xmlns="http://schemas.xmlsoap.org/soap/envelope/">
    <faultstring>Analyseur : La syntaxe pour « GET » est incorrecte.</faultstring>
    - <detail>
    <Error ErrorCode="3238920194" Description="Analyseur : La syntaxe pour « GET » est incorrecte." Source="Unknown" HelpFile="" />


    (The message is in french. it says GET syntaxe is incorrect)